Pegasus R6 Not Recoginized by M1 Max Mac studio

  • Last Post 24 May 2023
  • Topic Is Solved
Evan McGlinn posted this 24 May 2023

I have two Pegasus to R6 Raid drives configured Raid 6 and I just purchased a new Mac studio running Ventura.

I purchased a thunderbolt-to-USB-C adapter and when I plug it in the drives light up but they're not recognized by Finder. I read about a rather complicated firmware update on the Promise site which you can read here...


that That seemed a little difficult for me to do, and I was worried that it might somehow corrupt the desk. Is there an easier solution to this. How do I get the Mac studio to recognize my Pegasus to our 6 Ray Dr. Thank you.


Order By: Standard | Latest | Votes
R P posted this 24 May 2023

Hi Evan,

The main difference between the Intel macOS and the M1 macOS is that the M1 macOS does not come with a device driver for the Pegasus pre-installed.

If you install the Promise user space driver you won't need to change the boot policy. This is the latest user space driver.

You might also want to install the Promise Utility to manage the Pegasus. Since you have a Pegasus2, you should use this Promise Utility.

If your Pegasus 2 has old firmware, you may see issues like random disconnects and the Pegasus volume not appearing after a reboot. If these issues occur then you need to update to the latest Pegasus2 firmware, linked below.

There is also a Knowledge Base article on updating Pegasus1 or Pegasus2 firmware.


 I purchased a thunderbolt-to-USB-C adapter

Just to be clear, what you need is a Thunderbolt 3 to Thunderbolt 2 adapter. USB-C is just a connector type and it is used by both USB3 and Thunderbolt 3 and 4. The Apple adapter has always worked well.


Evan McGlinn posted this 24 May 2023

Thanks so much for writing me back. I downloaded all of the links that you sent me and I still can't get the drive to recognize on my Mac studio. By the way, I did purchase the correct adapter, which is the thunderbolt three to thunderbolt two adapter. I mispoke when I said it was USB C.

When I try to install the DEXT driver I get this message...


When I go to my privacy settings, I don't see anything that allows me to give that driver access. I went into the extension section and there's nothing there.




Overall, your instructions are great, but they don't match up with the real world situation of owning a Mac studio with Ventura. Lastly, when I open the Promise Utility, I don't see anything - it's just a black screen with some navigation at the top left - nothing like it was when I had my old system. Thanks for your help.


R P posted this 24 May 2023

Hi Evan,

I am personally not fond of the changes made to the settings app, but we will all get used to it eventually. Everything is there like it was before, but often one must scroll to the bottom of a long window to get to it (System Profiler I'm also looking at you).

After you install the driver, you need to give it permission to run, it's near the bottom of Settings > Privacy and Security.

This is what it looks like in the old Settings.

It's in the new Settings in Privacy and Security also, don't click on anything, just scroll down almost to the bottom of the page, it's there. Your screenshot shows it was not scrolled down far enough.

Once you give the DEXT permission to run, the Volume should mount to your desktop and the Promise Utility will see the Pegasus.

Evan McGlinn posted this 24 May 2023

Thanks so much. I was able to get it to work and everything seems fine now. I agree with you that the new privacy setting is a little difficult to navigate. I went into safe mode and changed the security settings. However, the information in the PDF you gave me misses some of the specific screenshots and steps so I would have your team go through a Ventura safe mode security change, and make sure that each step is documented so the end users don't get confused. Thanks so much for your help. I really appreciate it

R P posted this 24 May 2023

Hi Evan,

I went into safe mode and changed the security settings.

This is not necessary with the user space driver (DEXT), which is what you had installed. It is only necessary with the kernel space driver. I'd not worry about it changing it back. That setting only allows you to install 3rd party kernel space drivers, and you have none installed. But if you're concerned, you can reenable the high security setting.

I just examined the Ventura document that came with the DEXT and I don't see any issues with it. It does not tell you to change the boot security because that is not necessary with the DEXT. The screenshots are from Ventura. What am I missing?