Pegasus R6 had a Disk fail during rebuild and now Array is Offline

  • 103 Views
  • Last Post 12 March 2021
Shane Parkinson posted this 11 March 2021

While rebuilding PD1, PD6 got an error and was placed offline. This has subsequently placed the disk array offline. Is there a way to put the disk array back online and reset the PD6 back online and see if I can finish the rebuild?

I constantly have PD6 failing every couple of months. I think I've gone through 10 hard drives in the last two years. Is there a issue with Drive bay 6 in the Pegasus R6 18TB configured in Raid 5?

 

Tried to attach the subsystem log but I keep getting the message 'Sorry an error occurred"

Order By: Standard | Latest | Votes
R P posted this 11 March 2021

Hi Shane,

You'll need for force PD6 online. This can only be done from the CLI. To access the CLI open a terminal and type...

promiseutil

The CLI command to force PD6 online is...

phydrv -a online -p 6

This should result in the array being incomplete and needing to be accepted. Assuming your LDid is 0, the command to accept the array should be....

array -a accept -d 0

The LD should then be online but critical.

You should be able to start a new rebuild from the Promise Utility.

Hopefully PD6 stays online long enough.

Shane Parkinson posted this 12 March 2021

I tried the following command but it results in the error message below. I had actually tried this previously

phydrv -a online -p 6

Error (0x49841602): invalid physical drive id in data buffer

Not sure how to get around this problem? It doesn't appear in the Promise Utlity app either anymore so it's like it doesn't recognise that PD 6 is a disk

R P posted this 12 March 2021

Hi Shane,

PD6 is probably bad. It's been failing for awhile now, it looks like it has died.

Since you are 2 disks down on a RAID5, the LUN can't be brought alive.

It's possible that if you let PD6 cool overnight it may start when cold. There are many failure modes for electronics. You might try unseating the disk, pull it about an inch out and let it sit overnight and see if it comes online when you plug it back in. This is not guranteed to work, it probably won't work, but it's worth a try.

If the data is important you will need to work with a data recovery service.

Close