Pegasus hard reset

  • 202 Views
  • Last Post 27 November 2021
Alexander Snelling posted this 12 November 2021

I've got an original R6 with 2TB drives in it and something is not right. It will connect to Promise Utility if the drives are introduced one by one into the enclosure they appear as physical drives, however after about five or six drives are in the enclosure, something goes wrong and the connection appears to be lost. I've even managed to stripe an array and mount it but the connection seems very very unstable and is lost. In order to get it back online, I have  to unplug power and thunderbolt and then it appears and eveybhting seems hunky dory but then it goes again.

 

I've tried a different set of drives, a different computer, different TB cable and even a different power supply from another R6. Nothing works. Same experience.

I've narrowd it down to something on the board of the Pegasus. Is there any way to hard reset it? There appears to be a button on the back underneath the cover plate but this doesnt seem to do anything.

Anyone got any ideas? I realise it is EOL and not covered by Promise but maybe someone knows...

Order By: Standard | Latest | Votes
R P posted this 15 November 2021

Hi Alexander,

The motherboard (and every computer) does a reset everytime it's powered on.

There have been cases where the fans were blocked (usually by dust) and the Pegasus would overheat, but this does not sound like that.

It could still be a power supply issue. When a HDD starts up, it draws a lot more current, so the power supply may not be able to supply the startup current for 6 drives at the same time.

As a simple test, try inserting 4 drives and see if things are stable. It may be that the power supply can provide the current needed for fewer drives.

Alexander Snelling posted this 16 November 2021

Hi RP

I meant a firmware reset rather than just a power down as PU has consitently been suggesting there is a firmware upgrade available but never install it. I wondered if that was what the button on the back did.

You could well be right about the power supply as the R6 does mount with 4 drives but weirdlyPU will not recognise it. I tried a power supply from a perfectly functional R4 in the R6 and it exhibited the same behaviour however I'm not sure if the power supplies are the same from an R4 and an R6 - maybe the R4 power supply has a lower output, although they seem to match on the info.

Additonally PU dpesmt want to load and won't recognise the enclosure and terminal is now reporting:

 

promiseutil

zsh: bad CPU type in executable

 

Is my Pegasus finally dying?

R P posted this 16 November 2021

Hi Alexander,

promiseutil

zsh: bad CPU type in executable

Is your mac an M1?

Which macOS are you running and on which MAC? And which version of Promise Util?

Is my Pegasus finally dying?

Right now there seem to be other issues. If the volume is mounting, probably not.

Regarding the button you mention, I don't know what it is for. But firmware updates can be done from Promise Utility or the CLI, whatever the button is for, it can't be related to firmware updates.

Alexander Snelling posted this 17 November 2021

I've tried it on two Macs - this was a MacBookPro Intel i7 (10.5) and the iMac is an i5 running MacOS 11 (which was when the original problems started). Both have been great with all Promise stuff until now.

R P posted this 18 November 2021

Hi Alexander,

I'm not sure if any versions of Promise Utility support Leopard (10.5). You might try the FCS Pegasus 1 Promise utility.

You can use the latest Pegasus 32 Utility for macOS 11 (Monterey)

 

 

 

Alexander Snelling posted this 24 November 2021

Hi RP

Sorry I meant to say 10.15 not 10.5. - my mistake.

Big Sur could be an issue - I'll give it all a go when I've got a few hours. Thanks for your continued support.

Alexander Snelling posted this 27 November 2021

So just to recap on this Sherlock Holmes type journey. I don't think it is software related - either Mac or PU reasosn below.

My Pegasus R6 was inherited so I'm not sure of service history. It seems superficially fine but doesnt want to seem to mount although PU reports all disks OK and all other parts gets green ticks.

I have got as far as formatting a logical drive RAID 6 with it however this is where the problems start. After a short while the thing hangs and PU will not respond alhtough the moment I unplug the Pegasus, PU will start up (I know this is not good protocol but it elimiates PU from the equation). I have tried it on two separate computers with three different start-up drives running different Mac OSX 10.14, 1015 and OS11. Same problem. Eveyhting is fine until the 5th and 6th disks are added and then it kind of freezes up.

I even tried another power supply from a Pegasus R4 and I get the same problem so this seems to elimate the PSU. It must either be the motherboard or the PSU. The motherboard seems fine until 5/6 disks are added and even then not problems are reported.

From what I can see, the spec on the side of the PSUs from R6 and R4 are exactly the same however I am now wondering if the PSU is actually downgraded or has even been swapped out for one from an R4. Is there anyway to check if the power supply is strong enough for the R6? I can buy one but don't want to fork out $100 if this wont solve the problem.

 

Thanks in advance

 

Close