Pegasus 32 R8 not finding drivers

  • Last Post 07 December 2022
Preston Hooser posted this 07 December 2022

I have a Pegasus 32 R8 which was working fine until recently. Suddenly it seems that windows will not recognize the device correctly. It appears as "Unknown USB Device (Device Descriptor Request Failed)" in the windows device manager. I have tried uninstalling and reinstalling all the promise software, but it is not detected by the promise or pegasus utilities. I have tested it on a second computer and with multiple USB ports and cords. I have tried reseating all the drives. I have confirmed that ll drives and the power button on the enclosure have blue lights.


Any suggestions?


Thanks in advance.

Babatunde Akinkuolie posted this 07 December 2022

Please install the below driver for Windows and try again

if issue remains, kindly register the unit using the serial number by logging into and open a web support ticket with the service report of the unit attached so that we could assist you further.