Pegasus 32 mounts fine, disconnects after about a minute

  • 185 Views
  • Last Post 22 March 2024
Sean Holland posted this 13 January 2024

Connected to Mac Studio running Sonoma 14.2.1. 

The Pegasus starts up, it shows up in the finder, it connects with Promise Utility. Promise Utility shows everything fine. I can see all the files on the Pegasus 32. After a minute, it shuts down and then I get the "not properly ejected' message. I've tried different ports on the Mac Studio and the Pegasus and a different cable. Same result.

One thing is that there have been a couple of power outages in recently when the computer and the Pegaus were on. 

Does anyone have any ideas about this?

R P posted this 22 March 2024

Hi Sean,

In power outages there are often huge voltage spikes which can damage equipment.

The scenario where the Pegaus powers up, mounts, then dies after a minite or so is what is commonly seen when the power supply is weak.

It seems likely that this is the situation here.

In the past some forum posters have overed a replacement power from someplace, possibly EBay but I don't know. Apparently, the power supply had more connectors than the one in the Pegasus so they left them unconnected. They reported that this worked.

Another solution is to buy a used Pegasus chassis and swap out the power supply. You can fund used chassis on Google shopping, EBay and possibly other places like Amazon.

Close