Pegasus 2 R8 will not mount

  • Last Post 20 October 2023
Trey Neal posted this 31 August 2022

Pegasus 2 R8 will not mount. 

Mac Pro (Intel, 2019)

macOS Monterrey v 12.2.1

Array has been working fine - not changes to OS but will not mount.  Promise Utility sees the array and it has all green checks.

Attempting Disk Utility to mount results in the following error: error 0

Ran Disk Utility to no avail.

Firmware is 5.04.0000.64

Have created the Service Report from Promise Utility but don't see where to attach the file.


Order By: Standard | Latest | Votes
Trey Neal posted this 31 August 2022

Totally missed the buttons on the upper right. Report attached

Babatunde Akinkuolie posted this 31 August 2022

Hello Neal,

 Kindly create a support case at and attach the service report to the case so we can check and assist you further.

Below link is how to attach the service report to the web case

Nick Vincent posted this 23 July 2023

Hi Neal,

I know it's been a year but did you find a way to fiw your issue? I have *exactly* the same problem as what you described.

Hoping you managed to fix it last year!


Trey Neal posted this 02 August 2023

Support said to try Disk Warrior or Disk Saver, neither worked.

I tried Stellar Data Data Recovery which got it mounted but running First Aid (Mac) it failed again.

Unfortunately the only answer was to recreate the array if I had a backup of the data, otherwise I was out of luck.  So much for the relative safety of a RAID solution.

I will add that Mac will report that it cannot repair the drive and then will mount enough to see the contents which may allow you pull the data off of it before you recreate


Nick Vincent posted this 02 August 2023

Very insightful, Neal – thanks a lot.

Currently running Disk Warrior to try rebuilding directory but it is so slow, due to a reported disk malfunction. They say I should leave it up running for up to a week like this... Let's see...




Tajkond Sornprasith posted this 20 October 2023

I have the same problem with Pegasus2 R4 (M1 Studio) i'd try to fixed it with Disk Utility"First Aid" then click the volume Mounted again. The volume Pegasus2 R4 work as well. Maybe this solution helpfull

My english bad 

Nick Vincent posted this 20 October 2023

Thanks for your input, Tajkond... In my case, the P2 R6 was probably damaged: I tried everything to fix it (Disk Utility, Terminal, DiskWarrior...). In the end, I bought a Pegasus1 R6 second hand and swapped all the HDDs in the same order. It worked.