Pegasus 2 R4 not mounting

  • Last Post 13 September 2021
Yuval Tresser posted this 09 September 2021


My R4 was working well until 2 days ago.

I was modifying some pics through the Apple photos app when it crashed.

Since then, it powers on but does not mount.

I tried all the basic recommendations: switched ports, bought a new thunderbolt cable, tried it with another mac.

Nothing happens.

The drive does not mount, it does not show up on disk utility nor does it show up on the promise utility.

I am depserate! Please help!


After over 48 hours or so the drive booted up and seems to be working normally... not sure if this a temporary fix as I did nothing to make things better.

Is there a way to check what went wrong to ensure that it won't happen again?

I am running the media patrol to see whther it detects anything. 



Order By: Standard | Latest | Votes
Raghuraman Kannan posted this 10 September 2021

Hi Yuval,

We need to look at the logs to check for any events which affected the unit.

Please register yourselas as a user at and open a case with Service Report.

Steps to Save the report.

1) Open Promise Utility.

2) Click subsystem information icon on the top of the window.

3) Click the lock symbol on the left bottom corner of the screen to unlock the utility.

4) Click on save service report button to save the subsystem report and attach it to the case.


Thanks !


Jade Jesus posted this 13 September 2021