Pegasus 2 R4 - Mac Pro 2019 - USB C

  • 111 Views
  • Last Post 11 February 2020
  • Topic Is Solved
Peter Warrick posted this 10 February 2020

Is it possible to get a Pegasus 2 R4 working with the new Mac Pros? I have a USB - C to Thunderbolt adapter and have plugged the RAID into a USB C port on my new Mac Pro but it does not show up in my system. 

I installed the latest driver from this website but that didn't appear to affect it at all. 

Does it require a specific adapter or is it just not compatible at all?

Welcome any comments here before I spend too much time trying to get this to work.

Regards,

Peter

Order By: Standard | Latest | Votes
R P posted this 10 February 2020

Hi Peter,

I am not sure whether the Pegasus 2 drivers are Catalina compatible, but I am sure that you need to go to the security window of Settings and give any third-party driver or program permission to run. I suspect that this is the problem. The kext won't load until after u you give it permission.

Peter Warrick posted this 11 February 2020

Looks like the .kext didn't get installed. I ran through the installation instructions and looked at the system information to check for the extension but it was not there. 

Double clicking on the .kext brings up an alert that it doesn't know what application to use to install it. 

It's not a Catalina thing as my old MacPro (2013) is able to mount the R4 no problem and it's running Catalina.

A bit stumped here. 

Peter Warrick posted this 11 February 2020

*** UPDATE ***

Ok I managed to get the kext to show up in the system information. I just re-ran the installer and that worked. However it says NO for both notarized and loaded. So for some reason its not loading.

So I took your advice and I found the location in the security settings and enabled it. But still it shows as not loading.

I then put it back on my old mac and found it needed a firmware update. I switched back to the new mac. Still same problem. 

Peter Warrick posted this 11 February 2020

Ok. R P's response was the correct one (with my added part about reinstalling again). The last issue was a bad cable. :( Got it working!!! :)

Close