Pegasus 2 R4 - Disk suddenly not appearing

  • 317 Views
  • Last Post 10 September 2021
Jacob Greco posted this 10 September 2021

2 days ago I successfully managed to install a Gigabyte Titan-Ridge 2.0 device into an Asrock x470 SLI/AC motherboard. All I did was plug it into the PCI slot, plug in the power cables, and the USB cable. Then, I installed firmware version 23 of the Thunderbolt Control software. I read on a forum somewhere that anything after this point wont work in my situation. 

It's all been working fine the last 2 days, but this morning I turned my machine on and noticed the drive is being recognized in the Thunderbolt software, but not on Windows itself or in the Pegasus Utility. 

I've tried disconnecting the Pegasus, shutting it on and off, as well as the desktop, but it continues to only been seen in the Thunderbolt controler software and no where else. 

I dont understand why it's doing this all of a sudden when it was fine for the last 2 days. If anyone has any ideas for how to resolve this, it'd be greatly appreciated. 

Jacob Greco posted this 10 September 2021

I tried reinstalling the Thunderbolt software which seems to have now made the problem even worse. After reinstalling and attempting to open it, I get this:

Close