Pegasus 1 R6 - Bay 1 not recognizing drive after firmware update

  • Last Post 14 August 2019
Dz Trucktion posted this 12 August 2019

Hey everyone. I had a bad drive in Bay 1 of my Pegasus 1 R6, I was trying to get everything ready for when I got my new drive so I updated the firmware and the Utility to the latest version. The drive was red before the update - so I know that it was working - and when I update the firmware, the red light went away. I didn't think much of it until when the replacement drive came in and I plugged it in and it didn't show up in my PD in the Utility.

I then took the drive out of bay 2, it was working, and plugged it into bay 1 and it never showed up in my PD.

I then tried to take the new drive from bay 1 and plug it into bay 2 and showed up in my list of PD's instantly.

I cleared all settings set the unit to factory default, hoping clear out any weird settings or preferences, that didin't work.

I then tried to downgrade the firmware, that didn't seem to help either.

At this point, I am not really sure what else can be done. The data on the drive isn't important, but it would be nice if I didn't have to re-copy it all.

Any help would be greatly appreciated.



Ranjith kumar posted this 14 August 2019

Hi Dz,

In order to assist you on this issue, we need to analyse the subsystem report, so kindly save  it and create a web support case by login at where you can attach the report.

Also don't try to downgrade the firmware, it may cause issue to the unit.

Follow below steps to save the subsystem report:

- Open promise utility
- Click subsystem information icon on the top of the Promise Utility window
- Click the lock symbol on the left bottom corner of the screen to unlock the utility
- Click on save service report button to save the subsystem report.

Below is the Promise KB link to know how to attach files to the web support case:

Note: If you are unable reply to this web support case, it could be a issue with the pop up blocker on your browser.
Please disable the pop up blocker and try to click on the case ID to open.