NS6700 boot into safemode only after fail firmware update.

  • 512 Views
  • Last Post 18 May 2023
Dung Nguyen posted this 27 April 2023

I have an NS6700, The firmware update failed,  I tried to reboot and also try to factory reset.  But the device is booting into safemode everytime. 

system boot into safemode, it does not get an  ip address so I cannot access to flash the firmware again.

Connected a monitor and keyboard I can see the device is booting up to SLAX safemode

 I was able to hit the "TAB" key to see the boot option, this is what i see in the boot parameter:
/boot/safe-k initrd=/boot/safe-r i8042.noaux ramdisk_size=272384 root=/dev/ram0 rw console=tty1 ;telinit~4

Does anyone have the working NS6700 that could share with me the normal boot paramenter.  Any help would be really appriciated.

The Promise only help for pay support.

Order By: Standard | Latest | Votes
R P posted this 17 May 2023

Hi,

Took awhile to find my NS6700. I do not have any technical documentation on it, but I do have a few observations.

1. The failed firmware update may have done some damage. Or not, but it's a possibility.

2. If you connect to the VGA port and watch, when you press the power button in the lower left for about 6 seconds, it will shudown the NS6700 and one of the things you will see is a Clear Boot Flag message. Potentially this might clear the safe mode boot.

3. The IP address (or DHCP) can be set from the front panel. I don't know if this also works in safe mode.

4. There is a way to get a servce report. From the product manual...

5.3 How to use Promise USB Retrieval to export system information
With the Promise USB Retrieval application, you can easily export the system information to the log file.
1. Download the SmartStor USB Retrieval application from Promise’s Website.
2. Copy “OPAS_general.zip” to your USB Pen Drive.
3. Insert the USB Pen Drive into the USB port on the front panel of NAS.
4. The message displayed on the LCD to indicate that USB Retrieval is progress.
When done, you will be prompted by the message displayed on the LCD, or a “beep” sound by the system.
5. Remove the USB Pen Drive. The log file that contains the detailed system information will be saved automatically in the “OPAS_OUTPUT” folder of USB Pen drive.

The file OPAS_general.zip is abailable from the downloads page or from this link.

It may or may not work from safe mode, but if it does it will give you more information about the status if the NS6700.

Dung Nguyen posted this 18 May 2023

Thank you for replying, 
The powerbutton on the bottom left does lite up red, but it doesn't doesn't do anything if i hold it down for 6sec or longer.

The USB with the OPAS doesn't do anything for me before either, i'm going to try again.

If you have a VGA monitor connect to the bac and connect a keyboard to the back, when the system boot up after the bios screen, you can hit TAB and it will take you to the "Thank you for using Slax"

I have seen this before, but i beblieve there would be 2 options.  

If you able to connect a keyboard could you please help me get the boot parameter for the normal boot?  By keep hitting "TAB" on on the keyboard after the the bios screen

You can see the safemode boot parameter from the photo that i took:

> /boot/safe-k initrd=/boot/safe-r i8042.oaux ramdisk_size=272384 root=/dev/ram0 rw console=tty1 ;telinit~4

 

Thank You.

 

 

 

 

Dung Nguyen posted this 18 May 2023

When allow the system to boot into safemode, i can see the console, it show eth0 link up, it show httpd start, it show smb service start, but i'm not see the IP, SmartNAVi soft does not detect the NS6700, and i'm not seeing a DHCP lease IP address.

When boot into safemode, the front panel just show "The promise" logo,  the menu button does not responsed when press.  The power button does response and shutdown the system.

 

R P posted this 18 May 2023

Hi,

One question. Did you load the latest NS6700 firmware? It comes with this warning...

The NS6700 default memory is 1GB, this update is only for NS6700s with 2GB of memory.

I don't know what happens if you load the 2GB update on a 1GB NS6700, but booting to safemode may be the result.

If you have 1GB you should use the firmware before this, v3.0029.

That being said, as near as I can tell the normal boot parameters are

/boot/kernel initrd=/boot/rootfs i8042.noaux ramdisk_size=65536 root=/dev/ram0 rw memmap=128M$512M vmalloc=256M console=tty1 console=ttyUSB0,115200n8;telinit~4 BOOT_IMAGE=/boot/kernel

 

Dung Nguyen posted this 18 May 2023

Thank you for the normal boot parameters, 
I'm getting the "Could not find kernel image: /boot/kernel"

for the firmware with the 2GB requirement, I have upgraded the system to the 2GB RAM, unless it depend on other hardware of the NS6700, that firmware should just work.  I wonder if they refereing to the onboard flash memory the system RAM.

I have tried to configured the IP address at the boot parameters and i see that the system took the IP but I can't ping that address.

 

I have try to change run level so i can look at the FS structure, but I can't seem to get to console.

Dung Nguyen posted this 18 May 2023

Ok, I got it fixed.

I was looking for way to get to the console, the NS6700 does not have a serial port.  I remembered i have a USB-2-Serial dongle, connect that to the USB port on the back of NS6700 and connect that to my dell desktop using a serial cable.

 

I tried few passwords this one seem to work,  user/pass:  admin/admin

run ifconfig give me the ip address of the NS6700, it seem to be default to 192.168.1.1

At this point, I used my laptop, config the ethernet port ip address on the laptop to be 192.168.1.10 connect my laptop ethernet directly into the eth0 on the back of the NS6700 and I was able to access the NS6700 web gui using http://192.168.1.1

 

From here choose the firmware and wait for it to be done it asked to reboot the device for the firmware to take effect once upload is completed

 

Before reboot, power off the system put all my drives back, system boot up normal and all my files still intact.

 

In Short for those who have the issues:

1) connect ethernet port on your computer to the first ethernet port on the NS6700
2) change the ip on the ethernet port on your laptop to be in the same subnet as the NS6700. Use 192.168.1.10/255.255.255.0
2) Access http://192.168.1.1 from your computer to reflash the firmware.

Thanks RP for help.

R P posted this 18 May 2023

Hi,

I had some updates, but it looks like they are not needed. But a few comments anyway..

I was looking for way to get to the console, the NS6700 does not have a serial port.

I believe the console session is what you see from the VGA port.

If a 1GB NS7600 was upgraded with the 2GB image, there seem to be two solutions.

The first is to upgrade to 2GB of memory (you'll need a comparable 2GB SODIMM) then follow the process above.

If upgrading the memory is not an option, and if the safe mode from the 2GB image will work with a 1GB NS7600 (which has not been tested), then it will probably work to downgrade the firmware to the last 1GB image.

Lastly, nice work Dung.

Dung Nguyen posted this 18 May 2023

The VGA show output but it's not a shell/conosle where it can take input from keyboard.  But the USB to serial allow me to interact with the sytem.

I have the 1GB system, but upgrade to 2GB RAM, running the the old firmware no issues.  But installing the new firmware with 2GB requirement will still fail and stuck in safemode.  Go back to the older firmware will work with no issues.  

I see that the new firmware allow  using 6TB drives with FS larger than 16TB. I'm already running 4x6TB drives but in a raid10, so that did not go over the 6TB limit.  I did have some 22TB drives that i was thinking to used that's why i upgrade to the new firmware.  Since it's doesn't work, I'm probably going to use FreeNAS for those drives.

Close