Not Mounting or showing in Promise Utility- Pegasus3 R6 or Pegasus2 R8

  • 218 Views
  • Last Post 13 February 2022
Sean Bryan posted this 02 February 2022

I upgraded from a 2015 iMac with a 4GHz Quad-Core Intel Core i7 to a 2022 MacBook Pro 16inch 2021 with M1 Max.

When I trie to cponnect either my Pegasus3 R6 or Pegasus2 R8, it is not mounting, nor is it showing in the promise utility.

When I tried to connect it back to my old iMac, the same problem occurred. 

The devices are showing in the system report of both computers, and all the lights on both units are blue. Both computers are running Mac OS Monterey Version 12.1, and the promise utility is up to date with version 4.06.0000.01 (C02).

I tried everything I found in this forum and others to no avail. All sorts of re-starting processes, using different cables, only one at a time instead of daisy chained, etc. 

 

Please Advise!

 

 

Order By: Standard | Latest | Votes
R P posted this 02 February 2022

Hi Sean,

The M1 MACs don't include a Pegasus Driver so you will have to download and install the latest Pegasus32 Driver.

Be sure to follow the instructions in the zip, you'll need to enable 3rd party drivers to run on Monterey. And once that is done you'll also need to enable the Pegasus Driver in the Security settings.

Sean Bryan posted this 05 February 2022

This worked well, Thanks!!!

Lewis Harvey posted this 13 February 2022

On my new MacBook Pro M1 Max, Monterey did come with a Pegasus Driver in the HD/System/Library/Extensions folder, but it will not load because it is compiled for intel not arm-64 (supplied Version: 6.2.13, Copyright (c) 2010-2019). When you install the latest driver from Promise (Version: 6.2.17, Copyright (c) 2010-2021) it will load because it is compiled to run on the M1. One disadvantage of having to use the newer version is that it gets installed in the HD/Library/Extensions folder and to load these extensions you need to lower the level of security to allow for trusted developer extension to be installed (Promise provides clear instructions on what to do). But a consequence of lowering the security levels is that you can not use Wallet and ApplePay on the computer: It requires the highest level of boot security. The only solution (I think) is for Apple to supply the newer driver as part of the System/Library so that it will be allowed to load with the highest boot security enabled.

Close