Need a little help with an E610f

  • Last Post 06 June 2023
  • Topic Is Solved
Mark Beazley posted this 07 May 2023


I just purchased a used E610f and am in the process of setting it up.

I have it connected as DAS to a 2008 XSERVE.

It is showing up in Bonjour but I'm still not sure if it is a MAC version or Channel.

I'm having the following issues:

I can't log into the device under high siera because I'm getting a certificate error "certificate is using a broken key size"

I can attempt to login by accessing the IP through safari on a VM of Mac OS Server 10.6.

Unfortunately the default administrator/password login doesn't work so I'll need to reset the password.

I'm looking at the guide at "" but I'm not really sure which linked CONFUSER file I should use.

If it helps, under system information on the Xserve's fibrechannel pane it lists the following for all 4 Fibre channel domains:

Vendor: LSILogic

Product: LSI7404EP-LC

Revision: Firmware


Also, one more question... can I connect via the DB9 serial on the xserve to the DB9 on the controllers or do I need to make a DB9 to RJ11 cable to connect to the CLI?


Any help would be greatly appreciated




Order By: Standard | Latest | Votes
R P posted this 08 May 2023

Hi Mark,

The easiest was to tell the difference between MAC and channel is the controller memory. The channel Ex10 shipped with a 512MB DIMM in each controller, the MAC version shipped with 2GB/controller. Although the user can upgrade the memory, few did.

Also, the firmware version number contains a vendor code, Apple's Vendor code is 2270, so if the firmware version contains 2270, it's a MAC SKU. The channel vendor code is 0000. I recall that the login message on the serial console contains the firmware version.

Also, one more question... can I connect via the DB9 serial on the xserve

Yes, it's a standard serial port and works well. My old xserve was finally retired, but I would often use it to connect to storage.

via the DB9 serial on the xserve to the DB9 on the controllers

No, the DB9 on the controller is for UPS, The serial connector is RJ11.

This kind of serial cable is not standardized and each vendor wires their DB9 to RJ11 cable differently. So such a cable from amazon or ebay may or may not work. You can purchase a Promise cable from the PromiseShop.


PROMISE management cable: 200cm 6 Pin.DB9=>RJ11


Mark Beazley posted this 08 May 2023

Thank you so much for the response. I'll pull one of the controllers when I get home and check the memory. I ordered the serial cable from promise last night, so with any luck, once it arrives, I'll install the correct confuser file and be able to get it up and running. 

Mark Beazley posted this 16 May 2023

I have recieved the cable and am able to get a serial connection with the unit from my xserve.

I have tried following the guide. The xserve is running an ftp server and I am connected via zterm.

I can set the date and time (defaults to one day prior to the actual date for some reason.

I can set a static IP In this case, with subnet of and gateway of

the xserve is set to

i can successfully ping both the xserve and the gateway.

I have set the root folder for the ftp server and it includes the E610f Mac confuser file.

however, when I following the instructions, here's where it goes of the rails.

When I run "ptiflash -t -h -f ex10_confuser_10_6_2270_00.img"

the system pauses for a moment, maybe 3-5 seconds and outputs:

"Error can't load 'ex10_confuser_10_6_2270_00.img': operation timed out

Error error transferring file over tftp!



I have tried changing IP addresses, running ethernet directly to the second xserve ethernet port and bypassing the switch... I'm not sure where to go from here.


Any help would be greatly appreciated




R P posted this 16 May 2023

Hi Marl,

The update is via tftp, not ftp. macOS has tftp builtin, but there are no tools to configure or use it.

There was a handy macOS program called 'tftp server', but it looks like it's discontinued and no longer available.

If you have access to a Windows laptop I'd suggest a program named tftpd64.

Otherwise you are left working from the command line in macOS.

Mark Beazley posted this 16 May 2023

finally got it flashed. I ended up runing tftpd64 on a windows laptop as recommended. I can only assume apple has done something in the OS that affects FTP. I can connect via ftp from other macs, but it pops up a dialog prompting a user password or select guest and there is no way to do that in ptiflash

Mark Beazley posted this 17 May 2023

just another update... I was able to start configuring... unfortunately out of the 16 drives I had, only two have a 512 block size, 4 are Sata (fortunately I have 16 mux adaptors) and the rest seem to be 520 block size drives. I don't have access to a computer that can read SAS drives so I don't have a way to low level format the rest of the drives to 512. Im currently initializing a logical drive with the six working drives, so I have hopes still.

Thank you for all the advice.

R P posted this 17 May 2023

Hi Mark,

That the drives are formatted with 520 byte blocks is unusual and unexpected.

There are only 2 options that I can see for the SAS drives, buy a SAS HBA or a SAS dock. Amazon has them...

The docks look more expensive than SATA docks, but one dock is still a lot cheaper than buying 12 new drives.

To boot linux without installing, you can prepare a liveCD or a liveUSB and boot from that. It can take a long time to boot from a CD (if you have a burner), the USB is much faster. You can install sg_utils on a liveCD boot, I'm pretty sure I've done this before.

Mark Beazley posted this 20 May 2023

Just one last question, I was able to exchange the 520 block size drives for 512 ones, so I highly recommend ocean-tech as an ebay surplus reseller.  I do know that when using SATA drives with the MUX adapter I'm limited to 2TB of useable capacity per drive. My question is:

If I populate all16 bays with 3TB SAS drives (HUS723030ALS640) with no SATA drives, therefore no MUX adaptors, do I still have the same 2TB limitation on the Vtrak for Apple or would I have needed to purchase the E-Class version to use the full capacity of the 3TB drives?

I'm trying to decide whether to pick up 4 more drives to replace the 4 3tb sata drives already installed and use them in my Mac Pro, or, if I'm limited to 2TB even when running all SAS drives, to just keep them in the vtrak.


Thanks again for all of the help.


My tips for anyone else setting one of these up as DAS on a Mac:

if you need to reset the password, everything you need is in the guide linked in the 1st post. You will need a linux or windows TFTP server to run PKIFLASH to update the confuser image. (I tried several on the mac, over several days, but it would never connect. So I started rummaging through my closet to try and find my old general dynamics "toughbook" since it has a serial port. Then I realized that I'm an idiot and the only reason I needed a serial port was to "talk" to the vtrak and the PKIFLASH command just opened up an FTP client over the ethernet connction, so I could use pretty much any computer on my network. Once I made that realization updating the vtrak took less than 3 minutes including installing tftpd64) 

Once you can log in using administrator and password, you can just follow the Apple quick start guide linked here:

If you want to use the configuration scripts for the apple version at, you will need to use the wayback machine to get the archived version of the scripts or follow the manual configuration instructions at the bottom of the page, with one caveat: the instructions say that after you initialize the newly created logical drive it will be visible in disk utility. It was not for me. I had to follow the instruction at to configure LUN Mapping and Masking. 

The settings I ended up using for my xserve's fiber channel control panel for all 4 ports, ( I'm using the LSI Logic LSI7404EP-LC) were:

Port Speed: 4Gb/s

Port Topology: Point to Point

Enable Hard Loop ID unchecked

on the Vtrak side, in WebPAM Pro under administrative tools>fiber channel management I have the following settings on both ports of both controllers:

Link Speed: 4Gb/s

Topology: N-Point

Hard ALPA left at default

Those are the settings that got me up and running, so hopefully that can help out someone else who might be struggling with thiers.


however: In my fibre channel control panel on the xserve, at first, only domain 3 showed as online with a green dot, the rest had a red dot, I restarted and a domain 1 was the only one online. All 4 were in the system report but only the online domain had the SCSI target device and SCSI Logical unit nested below it. I shutdown the vtrak and xserve, unplugged all of the cables and reinserted them, powered on the vtrak, waited until the controller lights went from red to green and powered up the xserve. Now I'm only showing 2 domains instead of all 4 but both are linked and online, so I didn't want to touch them again and risk something not working anymore.

R P posted this 20 May 2023

Hi Mark,

If I populate all16 bays with 3TB SAS drives (HUS723030ALS640) with no SATA drives, therefore no MUX adaptors, do I still have the same 2TB limitation

No, the 2TB limit is from the AAMUX unrelated to the Apple and channel SKUs. Larger SAS drives can be used but I don't know how large. Check the compatibility list to see the largest drives tested.

One more thing, there is a yellow CMOS battery in the controllers that is probably dead. If the power to the chassis is removed some settings like ethernet address will not be retained. I don't know whether they are still available, but if power outages are a concern an the batteries can't be replaced a small UPS that could shut the unit down gracefully might be a simpler solution.

Regarding the FC issue, SFPs are replaceable because the write lasers have a limited life, they do burn out. I have a box of dead SFPs that I need to recycle.This is the first place I would look.


R P posted this 06 June 2023

Hi Mark,

It's a bit late for this, but I discovered that we have a KB article on using the macOS tftp server.

Perhaps someone reading this in the future will find this useful.

  • Liked by
  • Lyle Millander