Most download disk images are corrupted

  • Last Post 31 July 2023
Stanley Tran posted this 27 July 2023


I tried to download and update my Pegasus2 R6 firmware, all of the versions I tried are showing "The disk image couldn't be opened. The disk image is corrupted". See the attached screen capture.



Attached Files

Order By: Standard | Latest | Votes
R P posted this 27 July 2023

Hi Stanley,

You misunderstand, the firmware files need to be loaded with the Promise Utility. They are not Mac files and macOS does not know what to do with them.

From the Product Manual


Updating Firmware on Mac

The update procedure should be done before using the Pegasus32 with your Mac computer. Make sure to download the latest firmware from the PROMISE website at download.aspx and place the .img file on your computer.

To update the controller firmware:

1. From the Admin drop-down menu in the menu bar at the top of your desktop, choose Firmware
2. Click on the padlock icon to unlock the menu, and type in the password for your computer when
the prompt appears.
3. Click the Choose File button and locate the .img file you downloaded from the PROMISE
4. Click the Submit button.
5. In the Confirmation box, type the word “confirm” in the field provided and click the Confirm
6. The process will take several seconds to complete. Once the process has completed, it is
necessary to restart the computer. Note that Mac users who are connecting to Pegasus32
via USB need to shut down the host system, wait a few seconds for it to completely shut
down, then start it again in order to apply the new firmware. Once the computer is powered
on and booted up, you may continue to use the Pegasus32.


Note, it will take longer than a few seconds, it might take up to a minute.

Stanley Tran posted this 29 July 2023

Thanks for the reply and instruction. I tried, and I got an error "CRC check error for flash image". See screen capture below.

R P posted this 31 July 2023

Hi Stanley,

Please downgrade the Promise Utility to v4.06.0000.01. Then the update should work.

Also we have a knowledge base article for this.