Issues with Pegasus32 (exFAT) after upgrading the macOS 14 Sonoma

  • 151 Views
  • Last Post 07 December 2023
Nate McCallister posted this 05 December 2023

Since upgrading to from macOS 13 to macOS 14.1.2 (23B92) we have had many issues writing to our Pegasus32 R6 (RAID 6, exFAT.) 

When we reboot our MacBook Pro M1 Pro the drive gets checked by the OS in the background before it is mounted. This takes about 20 minutes. Once mounted the drive works normally for a little while and everything reports as green in Promise Utility Pro 23.4.1 and passes a First Aid test in macOS Disk Utility. 

After a little while we get error "The operation can’t be completed because an unexpected error occurred (error code -50)." from macOS when we try and write to the drive. 

After that we must reboot the computer and have the OS rescan and mount the drive (the drive fails to unmount without a reboot). We have tried reinstalling the kernel driver SR3.4.16 and then tried switching to the DEXT driver 21.1.0-2. (Never really been sure if the Kernal or DEXT drive is prefered based on the documentation) 

We have confirmed that the Mac is using "Secure Boot: Reduced Security" and "Allow All Kernel Extensions: Yes" and that the drivers extensions are allow to run in macOS System Settings/Privacy & Security. Never saw this issue in macOS 13. 

Nate McCallister posted this 07 December 2023

Just a little update, it seems the issue is caused by bug in the way macOS 14 Sonoma handles exFAT drives. Been running into dozens of posts that Sonoma is currupting exFAT drives if you shutdown or reboot the system without ejecting the drive first. I noticed that all my exFAT drives say "You have custom access" in Sharing & Permissions info and that a number of my folders are listed at "read only" if I look at the drive in Windows. I have stopped using the Pegasus with macOS Sonoma to avoid creating a bigger issue. 

Close