Macbook Pro 13" 14.2 vs Sanlink2 8Gbit FC

  • Last Post 20 September 2018
  • Topic Is Solved
Johan De Coninck posted this 19 September 2018

I have a client, a post production company with a big SAN infrastructure and they recently purchased a buch of Macbook pro's 13" to replace their older units. The units are connected to the SAN over 8Gbit fiber channel using Sanlink2 8Gbit units.

We installed the latest available SANlink2 drivers but we're unable to connect to the SAN on 2 out 3 units. When opening the system profiler and selecting the Thunderbolt tab it sees the sanlink but when you select the fiber channel tab we get a message saying that no fiber channel devices were found. I have raised this issue already 4 months ago spread over 2 case numbers with promise but never got a clear answer about how to solve this problem and I really need to able to offer some kind of sollution so any help or ideas about what might be causing this irradical behaviour would be appreciated.

Order By: Standard | Latest | Votes
P B posted this 19 September 2018

1. What version of macOS is this?

2. If it's macOS High Sierra 10.13, you're most likely running into User Approved Kernel Extension Loading
2A. You can read more about it here:

3. I suggest you read this forum post where I describe this issue and solution in detail:

4. You can also create a new case via

Johan De Coninck posted this 19 September 2018

Hello Thanks for your reply,

Yes the units run High Sierra. I will return on site in the next few days to check if it is the kernel issue.

The only strange thing is that the issue doesn't occure with the two new iMacs that were installed and that run  High Sierra also.

In any case I will keep you posted.

Johan De Coninck posted this 20 September 2018

Hello, Just to let you know that I remote reinstalled the drivers and allowed the install in the security panel and that it works now so case closed.