Mac OS Catalina 10.15.4

  • Last Post yesterday
Mike Malherbe posted this 5 weeks ago


My Pegasus 2 R2+ will no longer mount. The lights are on, but no connection. Firmware updated, but Utility will not open.

Help, please!

Order By: Standard | Latest | Votes
Ranjith kumar posted this 5 weeks ago

Hi Mike,

-Have you checked with swapping the Thunderbolt cable at different port of Pegasus and Mac?

-Is there any recent changes in the Mac OS like update?

Please reach us through for quick response.

Thank you,



Promise Team


Mike Malherbe posted this 5 weeks ago

HI Ranjith. I have responded on a separate post. Mac os Catalina 10.15.4. Power and drive lights are on. Have tried the other slkot for the Thunderbolt, also tried the USB. The Utility is also not working. Help!


Ranjith kumar posted this 4 weeks ago

Hi Mike,

Kindly check with different Thunderbolt cable if possible.

Also please create a web support case at for further assistance.


Promise Team

Earl Burns posted this 4 weeks ago


I am also having the same problem. Installed the updated utility. I also purchased a brand new thunderbolt cable from apple. Contacted tech support the the promise utility will mount but then when I re-boot it is gone.

I also tried swapping the slots.

Earl B

  • Liked by
  • Mike Malherbe
Howard Womersley posted this 4 days ago

I got a response from Promise Support.

The Promose Utility that works with the Pegasus2 R2+ is still not compatible with Mas OS Catalina (10.15). Their suggestion is to not upgrade to Catalina until the new utility is available. But they also do not have an esitmate of when this will be.

See other thread for more details:

Steven Taylor posted this yesterday

Apple has deployed a supplemental update for the problematic macOS Catalina 10.15.4, fixing some issues – albeit not the most pressing ones, and the worrying thing is, we’ve seen multiple reports popping up online of this update causing upsers portal