Let's hope this R6 Survived

  • Last Post 31 October 2020
Ian Bell posted this 07 July 2020

I've got a 10-year-old Promise Pegasus R6 with six Seagate Green drives (5TB each) loaded. This thing has been a tank. 

This morning a power transformer blew up in spectacular fashion a half-a-block away and likely surged my household. The only thing affected appears to have been my Pegasus. It threw an error on one of the drives.. fine by me! It's configured as RAID5 so I just swapped it out with a fresh spare, and expected it to rebuild. 

Some odd behaviour ensued.

First, it was double-beeping, to indicate the dead drive. It appeared to be running smoothly, howeever, as it was still mounted in the OS and was at least reading data.

The double-beeps stopped when I popped in the new drive. For a while.

Second, I was initially able to view the drive etc via the Promise Utility. This eventually stopped, shortly after I started working on it. I tried updating the drivers and the Utility just to be sure, but they appear to be unable to communicate.

After letting it do its thing for 6-7 hours upon replacing the drive I decided all was not kosher and started to try to diagnose the problem.

- After power cycling the R6, the beeping continues.

- The (replaced) dead drive (Slot2) looks like it might be restoring (blue activity lights), but after 8 hours or so.. nothing has happened.

- The power light appears Orange -- in the manual this is supposed to indicate it's booting up.

- I was able to briefly make the R6 happy by pulling all six sleds. Then, when I re-inserted them, it returned to beeping.

- The Promise Utility refuses to load the management screen, though the app is running. 

- The R6 is visible in Apple's "System Information" diagnostic tool as a Thunderbolt device. I can't remember whether it's supposed ot list the drives or not -- probably not.

- The double-beeping continues.

I wonder whether I interrupted a multi-day restore by rebooting the R6?  And whether that might have destroyed the RAID once and for all? Only the drives in Slot1 and Slot2 are showing activity. The lights on all the drives are now blue.

Order By: Standard | Latest | Votes
Ian Bell posted this 07 July 2020

Command line util displays no connected units. That probably isn't good.

Ian Bell posted this 07 July 2020

I shut off the Pegasus for half an hour and let it rest/cool.. Perhaps the demons left, or perhaps they just fell asleep. Rebooted the R6. The beeping has ceased apart from the usual bootup diagnostics..

I got the Promise Utility back up and running by installing Pegasus3 drivers + Utility. Not sure why things would have worked with the old Utility prior to this hitting the fan, as I'm on Catalina and have been for >6 mos., but namaste! 

Now the R6 has decided that the drive in Slot 1 is dead. I'm not inclined to believe it.

I went to the cmdutil and forced the Slot1 drive back online. Now attempting to rebuild but has been at 0% for a conspicuously long time. After half an hour it crept to 1%. So this rebuild could take a while.

Ian Bell posted this 07 July 2020

... and before I get dunked on for running green drives, these Seagate Barracuda ST5000DM000 5TB drives have been reliable and steady, though they spin at 5900 RPM. They've been in the R6 since 2015 and run 24/7/365.

I shucked them from a bunch of Seagate external backups I bought on eBay in Summer 2015 for $170CDN each. Cheapest 30TB disk cluster ever.

Let's see how this rebuild is looking this time tomorrow.

The R6's Power light is ORANGE while it's rebuilding, and the Slot2 drive is flashing orange.

Ranjith kumar posted this 08 July 2020

Hi Ian,

Please let us know the status once rebuild get completed. 
If you need any assistance, then kindly reach us through support,promise.com with subsystem report.

Thank you,


Promise Team

  • Liked by
  • Ian Bell
Ian Bell posted this 08 July 2020

OK. So, after an 18-hour rebuild everything was apparently hunky-dory.

Note that the first phydrv command was issued before I updated the firmware and power-cycled the Pegasus. The Slot1 drive displayed its "Forced On" status from last night's fiddling, but after the power cycle it seems to have returned to normal OK operations.

In retrospect, I probably did not need to swap out the original drive that was reported as having failed that started all of this.. I don't suspect either of the drives that were reported as DEAD by the utility actually were (the original 'DEAD' drive is now happily backing up my various computers on the LAN attached to a Time Capsule).

All appears to be well.. ALL LIGHTS ARE BLUE.

And my media is streaming error-free.

Ranjith kumar posted this 09 July 2020

Hi Ian,

That's good work, thanks for the update.

Please reach us if you any query.


Promoise Team

  • Liked by
  • Ian Bell
Riot Nrrrd posted this 31 October 2020


 Be glad you had a happy ending here.  I had an APC BackUPS-1300 UPS protecting my Promise Pegasus R6 for several years (along with my Mac mini and another RAID box, among other things).  Recently the UPS crapped out with an "Err02" on the LCD and a high-pitched scream that would not go away until/unless I powered off the APC unit, which of course yanked power to all of the aforementioned equipment.

After buying a new APC UPS, the Mac mini and the other RAID unit came up fine, but the Promise Pegasus R6 is now dead as a doorknob.  Power will not come back on and I have a $2,400 paperweight on my hand because Promise refuses to support anything other than their current product line.  The fact that there is no way to get it repaired or buy a replacement 0TB chassis (or a new 0TB chassis for any product, for that matter) is infuriating.  Not all of us are made out of money and can replace our RAID units whenever Promise comes out with a new product line!  😡