"Legacy System Extension" Warning / Catalina / Big Sur

  • 146 Views
  • Last Post 2 weeks ago
Farish Media posted this 09 December 2020

Aloha,

I'm randomly getting a "Legacy System Extension" popup warning on startup. Otherwise, my system is running fine.

What is the status of Big Sur support with the SANLink 2?

Also, I have installed the latest software (SR3.0.8) - even though the downloaded link and the driver/kext installed both say "1.8.2".

Is this correct?

Thanks for any information. 

Attached Files

Order By: Standard | Latest | Votes
Gautham Sakthi posted this 12 December 2020

Hello Farish,

Promise is currently undergoing certification testing for the Pegasus driver.

We do not know the status of Sanlink drivers. But it's likely that they will be out soon after the Pegasus driver is released.

For further investigation about the Legacy System Extension and SR3.0.8, I request you to create a support ticket at support.promise.com so we can further investigate.

R P posted this 12 December 2020

Hi Farish,

Promise is aware of the upcoming changes to the macOS drivers. But I do not have an ETA for any updates to address this.

Thomas Agatz posted this 12 December 2020

Hi Farish,

Promise is aware of the upcoming changes to the macOS drivers. But I do not have an ETA for any updates to address this.

 

Hi @R P

Are you working hard on this??? I hope you know, that a lot of your customers are left behind with no connection to their drives :((( I can't access any of my photography work for my clients, and is forced to look for another solution than my Pegasus next week :((

R P posted this 14 December 2020

Hi Thomas,

You are confusing the 'Legacy System Extension' warning issue with the M1 driver issue. They are two completely different issues.

Here's more info on the warning.

  • https://www.macrumors.com/2020/03/25/mac-legacy-system-extension-warning/

Thomas Agatz posted this 14 December 2020

Hi R P

I'm sorry, your right.

R P posted this 15 December 2020

Hi Thomas,

I have just discovered that the M1 Pegasus driver (v6.2.16) is now available for download on the Promise support page.

Or you can download it from this link...

Please read the install guide. Big Sur has new security features that must be modified.

----

Enable System Extensions

M1 Mac running macOS 11 or later requires a one-time change to the Boot Policy before you install
the
Promise Pegasus Driver. Follow the instruction in this section if the Boot Policy setting has not
yet been changed. First check to see if the Boot Policy needs to be changed.

Farish Media posted this 2 weeks ago

Any updates or work arounds for SanLink2 on Big Sur?

Ranjith kumar posted this 2 weeks ago

Hi Farish,

Promise have released driver for BigSur compatible to Sanlink2, kindly

go to our download section and download the driver as per your Sanlink model.

Thank you

Regards,

Promise Team

Ranjith kumar posted this 2 weeks ago

Hi all,

The SANLink driver Service Release 3.0.10 which supports both Intel and M1 Big Sur is availbale for download on the support page.

You can also download it from this link...

Please follow the included install guide.

 

Regards,

Promise Team

Close