Latest Monterey OSX 12.1 Update results in "Disk Not Ejected Properly"

  • 1.1K Views
  • Last Post 03 February 2022
Edward K posted this 14 December 2021

M1 Macbook 

24Tb R8 Pegasus 2

Monterey 12.1

 

Seems to repeatedly disconnect and reconnect (see attached which is result of 1 hour of system sleep)

Order By: Standard | Latest | Votes
Nate Tomerlin posted this 23 December 2021

This same thing is happening to me. I was previously using a late 2013 MacPro (trashcan) with a Pegasus2 R4 8TB unit. Worked flawlessly for almost 8 years. My Trashcan is running Catalina (10.15.7). I just received my new M1 Max macbook (Monterey 12.0.1) and experienced these same ejections. At first I thought it was because of the sleep / power saving settings but after adjusting those to never go to sleep, never go to screen saver, and never put HD to sleep, the issue persisted. Even worse, the drive ejects *when I'm copying files from it to the macbook's internal drive*. This happens 100% of the time, making the drive unusable on the macbook. I hooked it back up to the MacPro Trashcan and it works fine. I also have been using a client's Pegasus32 R4 unit and it has the same issues. Firmware on my drive is up to date, the firmware on my client's drive is not. After some googling, these issues seem to be very common in Big Sur and Monterey. Promise has been responding to my ticket but so far we've just reached the standard troubleshooting questions of "have you tried different cables and ports, etc.". I'm on day 3 of back and forth with support and still no resolution. Luckily I can still use the drive on my Trashcan but unless this gets resolved I'll have to look elsewhere for a new unit because this is not cutting it.

 

M1 Macbook 

24Tb R8 Pegasus 2

Monterey 12.1

Seems to repeatedly disconnect and reconnect (see attached which is result of 1 hour of system sleep)

Edward K posted this 12 January 2022

Nate, Did you find a fix???

 

 

 

I've struck out

 

 

This same thing is happening to me. I was previously using a late 2013 MacPro (trashcan) with a Pegasus2 R4 8TB unit. Worked flawlessly for almost 8 years. My Trashcan is running Catalina (10.15.7). I just received my new M1 Max macbook (Monterey 12.0.1) and experienced these same ejections. At first I thought it was because of the sleep / power saving settings but after adjusting those to never go to sleep, never go to screen saver, and never put HD to sleep, the issue persisted. Even worse, the drive ejects *when I'm copying files from it to the macbook's internal drive*. This happens 100% of the time, making the drive unusable on the macbook. I hooked it back up to the MacPro Trashcan and it works fine. I also have been using a client's Pegasus32 R4 unit and it has the same issues. Firmware on my drive is up to date, the firmware on my client's drive is not. After some googling, these issues seem to be very common in Big Sur and Monterey. Promise has been responding to my ticket but so far we've just reached the standard troubleshooting questions of "have you tried different cables and ports, etc.". I'm on day 3 of back and forth with support and still no resolution. Luckily I can still use the drive on my Trashcan but unless this gets resolved I'll have to look elsewhere for a new unit because this is not cutting it.

 

M1 Macbook 

24Tb R8 Pegasus 2

Monterey 12.1

Seems to repeatedly disconnect and reconnect (see attached which is result of 1 hour of system sleep)

坤 钟 posted this 01 February 2022

My M1 MAX is also in the same situation, I am worried that such a forced ejection of the hard disk will damage it

R P posted this 02 February 2022

Hi,

There is a new M1 driver on the downloads page dated 1/27/2022. Please try this driver.

Edward K posted this 03 February 2022

Hi,

There is a new M1 driver on the downloads page dated 1/27/2022. Please try this driver.

坤 钟 posted this 03 February 2022

Hi,

There is a new M1 driver on the downloads page dated 1/27/2022. Please try this driver.

Try downloading a Jettison that automatically ejects the drive before going to sleep, which avoids the false prompt, the only solution I can think of at the moment.

Close