Building a raid0 with 4 or 6 drives as well known and wich worked fine on all other systems.
Creating a 24 or 36 TB APFS Volume. Filling this with approx. 18 TB of data. Everything is fine until now.

Adding more data will cause a Kernel Panic Fault (File System Driver) on macOS. Data are not malicious, tested fine on an 24TB device of LaCie 2BIG.

Subsystem Firmware, MAC driver and tools are up to date on 07.10.19.

After this once happens the Subsystem is somehow poisoned for all other High Sierra Systems. Only touching the Promise HDD icon will cause Kernel Panic Fault on all High Sierra Systems. Sometimes also access to the subsystem while boot-process will cause Kernel Panic.
Trying this several times it was possible to execute fsck_apfs which reports unrecoverable errors, but filesystem fine. (How can this happen?)

Trying the (poisoned) subsystem on Mojave Systems without any changes, no problem is detected. Also no problem in the logs of Pegasus. Also fsck_apfs reports no problems.

Back to High Sierra. Kernel Panic resists.

Deleting APFS filesystem and all volumes on Pegasus. Rebuilding all this new. Kernel Panic resists on empty new filesystem. Changing all drives to pass thru and formatting new on APFS, then back to the former configuration will help. New and empty system will work fine. It does no matters if the new system is build on High Sierra or Mojave. The system is also poisoned on MACs whithout Promise driver and tools.

Doing the former procedure: Kernel Panic returns with all other problems. Reconfiguring from 4 drives (24TB) to 6 drives (36TB) has exactly the same result with the same metric.

It is possible that we have no experience with Pegasus and a huge amount of data, as we use it to quickly save lots of big VMs, not to store a huge amount of data. This will be done on Synology NAS subsystems.

Unfortunately we have to remigrate ALL our computers in our lab (30) to High Sierra because of the incompatibility of Mojave to elder Mac Systems. We cannot support two or three Versions of macOS. We have to use only one. And only High Sierra will run on all our MACs. So I really need a solution for High Sierra.

Did you ever know of this strange kind of problem and can you please help?