J4 Driver Update

  • 815 Views
  • Last Post 17 April 2022
Kevin wick posted this 24 December 2020

Where might I find a driver update for the Pegasus J4 to Big Sur Mac OS 11.x.x of is there going to be an update. I'm moving from Mojave to Big Sur.

TIA 

Kevin

Order By: Standard | Latest | Votes
Ranjith kumar posted this 30 December 2020

Hi Kevin,

As you know Pegasus J4 is legacy unit, so there is no further update on this.

But you  can try with below  latest driver which may work or may not for MAC OS 11.x.x:
https://www.promise.com/FileCruiser/MediaBank/Download%20Bank/Drivers/Pegasus/Pegasus32/R_MacDrv_V6_2_16.zip

Regards,

Promise Team

Kevin wick posted this 30 December 2020

Thank you, I give it a try.

As we all know it takes no time for something to be a legacy unit in today's world.

 

Robert Knickman posted this 15 July 2021

Thank you, I give it a try.

As we all know it takes no time for something to be a legacy unit in today's world.

 

Hi Kevin...

How did it go with the J4 Driver and Big Sur?

I'd like to upgrade to Big Sur but don't want to lose my J4.

Let me know please.

Klaus W. Brandt posted this 30 July 2021

 

Hi to everyone,

it works!
Mac mini 2014, macOS Big Sur, 11.4, Promise Pegasus J4.

After i'd installed the Driver: https://www.promise.com/FileCruiser/MediaBank/Download%20Bank/Drivers/Pegasus/Pegasus32/R_MacDrv_V6_2_16.zip

the Pegasus J4 was was instantly visible on the Desktop again! Great!!

Thank you!

Kind regards,
Klaus

 

James Camelford posted this 17 April 2022

Followup question .... April 2022.  For the Pegasus J4......

I am on Big Sur 11.6, Intel "TrashCan" MacPro (circa late 2013).  

I have repeatedly tried to install both the R4 software mentioned above....and re-install the J4 2016 software I had working on Catalina ... but to no avail.  It says it's installing it but when I check the system extensions in the system report it says it is 'not loaded' ... so until I can get it loaded the J4 drive is NOT visible on the desktop.

Has anybody else had luck with this ?

I have been watching for the permission to pop up in the Security & Privacy [General] pane - but it never does.  and I have re-booted.

I have even tried sudo kextload /Library/Extensions/PromisePegasusJ4.kext

and similarily for the R4 to force it .... so I am really wodnering if at this level of Big Sur these drivers are just not compatible.

Any suggestions ?

jc

Close