Invalid Upgrade File

  • 323 Views
  • Last Post 15 June 2021
  • Topic Is Solved
Terry Dunbar posted this 10 June 2021

I have a number of NS4300 units; most of which have had their firmware upgraded to what I believe is the latest version, 01.05.0000.12. Two of my units have firmware versions 01.01.0000.05 and 01.03.0000.06, respectively, which I would like to bring up-to-date. When attempting to upgrade the firmware of the unit with the oldest version, I get an "Invalid upgrade file!" message. I've copied the file from two different locations, the locations from which I believe the other units were upgraded successfully. Any suggestions?

Order By: Standard | Latest | Votes
Gautham Sakthi posted this 11 June 2021

Hello Terry,

You must have to unzip the downloaded file and choose the .upg file for the firmware update and also the firmware has to updated in incremental.

Kindly register the product at support.promise.com and create a web support ticket for further assistance.

Regards,

Gautham

  • Liked by
  • Terry Dunbar
Terry Dunbar posted this 15 June 2021

Hi Gautham

I incrementally installed all the firmware versions in order and that solved my problem. All of my SmartStor units are now running successfully with the latest firmware version.

Thanks for your help.

Terry

Close