Installed Latest Pegasus32 Driver (6.2.17) and Can't Get Driver (kext) to Load

  • 116 Views
  • Last Post 4 weeks ago
Douglas Garfield posted this 5 weeks ago

I can see the new driver in the Extensions section of system information but it says it's not loaded. The pre-installed(?) version 6.2.13 is. How do I get the new one to load?

Also, I can't get the Pro Utility to recongnize my unit which I assume is because I can't load the latest driver. The older utility works fine.

Running MacOs 11.6 on a 2019 5K iMac.

Thanks.

-Doug

Order By: Standard | Latest | Votes
R P posted this 5 weeks ago

Hi Douglas,

Which Pegasus do you have?

If you have a Pegasus Pro, the Pegasus Pro driver is different from the Pegasus driver. The 6.2.13 driver won't load for or work with a Pegasus Pro.

You can download the latest Pegasus Pro driver (v1.1.19) from this link.

If you have a regular Pegasus, then the inbox driver (6.2.13) should work fine.

R P posted this 5 weeks ago

 Hi Douglas,

My bad, the subject line says you have a Pegasus 32.

As mentioned previously, the 6.2.13 driver should work fine. I'm using it on an Intel Big Sur Mac with no issues.

There is an issue with the 6.2.17 driver. Apple has changed the way Big Sur handles kexts and this is causing some problems for all 3rd party drivers. We are working on it and will post a solution here as soon as we have one.

Regarding the Pegaus Pro utility (this was what confused me), some few are having issues with it working with supported non-Pro Pegasuses. We are also working to resolve this issue, please use the regular Pegasus Utility for now.

Douglas Garfield posted this 5 weeks ago

RP,

Thank you for the speedy reply. I wanted to make sure I wasn't doing anything wrong as I was just following the instructions to update to the latest driver/software/firmware. Anyway, I'll check back in the coming weeks/months for updates.

Thanks.

-Doug

Igor Ferigutti posted this 4 weeks ago

I have the same issue on Mac Pro 2019 / MacOS BigSur 11.6 / Promise Utility Version 4.06.0000.01 (C02) / Pegasus R4i (Firmware 6.04.0000.42).

R P posted this 4 weeks ago

Hi Igor,

At this point please continue using the inbox driver (6.2.13). As near as I can tell the 6.2.17 driver is more for the M1.

Close