DS4600 won't turn on

  • 51 Views
  • Last Post 3 weeks ago
lawrence mancuso posted this 12 September 2018

I just noticed that my Smartstor DS4600 wasn't powered on. I checked the power cable and power strip to make sure power is okay, still not powering on. 

New power supply required? Any instructions out there for confirming if this is the issue?

Order By: Standard | Latest | Votes
Pradeep Chidambaranath posted this 12 September 2018

Hi Lawrence,

Kindly mark and remove all the drives from the unit and try to power up the unit to see if the unit powers up without the drives. If the unit powers up, then one of the drive is creating an issue which might need further troubleshooting. If the unit doesn't power up then it could be an issue with the DS4600 unit. These units has reached its end of life and has a very limited support options.

Kindly go to https://support.promise.com to register the unit and create a support ticket to update us the status after preforming the above suggested steps for further investigation.

Regards
Pradeep C

lawrence mancuso posted this 07 October 2018

OKay I performed those steps and created a support ticket but haven't received a reply in some time...

lawrence mancuso posted this 3 weeks ago

So support hasn't been very helpful; their advice is to go buy another DS4600 and then insert the drives to access the data. When asked if any of their other current products were compatible, they weren't sure.

Does anyone know if there's any way to access the data off these four drives that were RAID 5 arrayed?

Barring that, anyone have a functioning DS4600 lying around I can borrow? :)

Close