"Device not found" after drive failed re-post

  • Last Post 21 June 2023
Graham Davidson posted this 21 June 2023

I originally posted this last year but never got a response, so thought I'd try again as there's a lot of data on the drive I'd like to retrieve. The post is as follow:


I'm running two Pegasus2 R4s on a win 10 system.

This morning I had a drive fail on the first unit. 

I had a look in the utility and could only see the second unit. I didn't think too much of it, then bought a replacement drive and popped it in. Now I'm getting four blue lights on the front of the unit but it's still not visible on the utility. I've tried using the thunderbolt cable from the second unit (which was still visible) and still not seeing it. 

I tried removing the new drive and putting it back in. Now, instead of all blue lights, I get 4 blue lights for the disks, but an amber light on the power button which changes to red after a minute and then the unit shuts down.

Any help would be greatly appreciated as I have 11 terabytes of data on there that I'd hoped would be safe because of using raid 5

Thanks in advance


R P posted this 21 June 2023

Hi Graham,

The primary reasons for issues like these are...

1. Pegasus is not seen on host computer:   Bad or intermittant TB cable, driver not installed or loaded or wrong driver installed.

If the other Pegasus2 volume shows up with the same cable that eliminates everything but an intermittant TB cable. If you have a 3rd TB2 cable, please give it a try.

2. Pegasus starts, then shuts down: Most likely a power supply issue on the Pegasus.

Since you have a working Pegasus2, you can always shut it down and swap the drives between the two and access the data from the working Pegasus2. This will allow for the data to be backed up elsewhere.

Most likely the issue is a power supply failure on the non-working Pegasus2. But it's hard to make a definitive diagnosis with the information at hand.