Dell Precision 5550 / XPS 15 / XPS 13 with Windows 10 can't see Pegasus1 R4

  • Last Post 27 March 2021
Dirk Hobman posted this 22 March 2021

I have a new Dell Precision 5550 laptop (which is basically a beefed-up XPS 15) running Windows 10. I'm trying to connect my Pegasus1 R4 to one of the thunderbolt 3 ports. Because the Pegasus R4 uses thunderbolt 1, I'm using an adapter to go from the R4's thunderbolt 1 cable to the thunderbolt 3 port in my laptop. Regardless of whether I use an Apple or thunderbolt 1/2 to thunderbolt 3 adapter, the Pegasus R4 refuses to show up. The Pegasus R4 is the *only* device I can't get to work on this new computer. I tested both thunderbolt adapters with numerous other thunderbolt 1 and 2 peripherals - an external hard drive, a thunderbolt dock, even a different RAID array by OWC - and all of these work just fine on my new Dell laptop using either adapter. Just not the Pegasus R4, which is the one thing I need to work.

I've tried loading every Windows driver version that Promise ever made for any Pegasus running on Windows. I've tried using different thunderbolt cables. I've tried booting the laptop with the Pegasus R4 already on and connected and tried connecting after the laptop has booted into Windows 10. Nothing seems to help. The R4 never shows up in the Device Manager or Disk Management utilities. It also never shows up under the Thunderbolt Control Center software on the laptop. I even backed up all my data, wiped the drives, reformatted them as NTFS, and that also did nothing. It's as if the R4 doesn't even exist. I also tested the Pegasus R4 on a new Dell XPS 13 and see the same problem there - the R4 just won't show up.

The Pegasus R4 is in perfect working condition, and I had put in all new disks about a year ago, so it's painful to watch that investment just disappear. I asked Promise about buying a different Pegasus2/3/32 R4 enclosure, but they won't sell me an enclosure without disks.

Until now I've been using the Pegasus R4 on a MacBook Pro with Mojave and with Windows 7 via Bootcamp. It works perfectly in both environments.

Any ideas would be massively appreciated.



Order By: Standard | Latest | Votes
Dirk Hobman posted this 27 March 2021

It seems this could be a driver loading issue. The Pegasus R4 runs fine on my MacBook Pro with Windows 7, and when I run driverquery under the command prompt on that machine, I see that stexstpt is a loaded driver. On my Dell laptop with Windows 10, however, stexstpt never gets loaded and never shows up under the driverquery command. Does anyone know how I can get stexstpt to load under Windows 10?

On both laptops I have installed the latest Pegasus driver for Windows.

Thank you!

Dirk Hobman posted this 27 March 2021

Also of note on the Dell: no matter what Pegasus driver version I try (and I've tried them all), when I uninstall it, I get the message "SYSTEM\CurrentControlSet\Services\stexstpt does not exist!". This seems to be referring to a registry entry. When I look that up in the registry under my Windows 7 system, that does indeed exist there. But not under Windows 10.

Given that this Dell is brand new as of 2021, it has me wondering if somehow Promise's driver installer isn't properly installing everything it should, as in this case for something else: