Compatibility with MacBookPro M1 Max (OS Monterey 12.1)

  • Last Post 24 January 2022
Jean Ladouceur posted this 23 December 2021

My Pegasus32 R4 don't mount on my new MacBookPro M1 Max.

Order By: Standard | Latest | Votes
Rick WS posted this 24 January 2022

Have the same. My M1 Max doesn't recognize my Pegasus 2R4.. I was wondering if it is due to the Thunderbolt to USB-C connector..but now with you people experiencing this with the 32 .. I'm beginning to wonder what is up at all. 

I'll look at your forum post Russ..


Hope it will help me too. 
I tried installing whatever already. 


Russ Pond posted this 21 January 2022

I got it working on my new M1 Max, but it took some setup and getting the drivers correcly installed. Here's my forum post about it.

R P posted this 20 January 2022

Hi Ralph,

You will not be able to delete any drivers in the /Systems/Library/Extensions folder, this is a protected area of macOS.

This is a macOS issue, if you really desire to remove it you should open a ticket with Apple.


Ralph Hodgson posted this 17 January 2022

I have the same problem with Pegasus32 R4. It was working after I downloaded the new driver but yesterday after a restart it no longer is accessible. When I look at the extensions in the Apple system screen I see 2 PromiseSTEX kext entries, one in Library  and the other in System folder. The Library one shows Yes and Yes to the driver checks but the System folder one shows No and No, as shown in attached screenshot.

I tried different ways of removing the System extension but I got permission denied messages:

sudo rm -rf PromiseSTEX.kext


rm: PromiseSTEX.kext/Contents/_CodeSignature/CodeResources: Operation not permitted

rm: PromiseSTEX.kext/Contents/_CodeSignature: Operation not permitted

rm: PromiseSTEX.kext/Contents/MacOS/PromiseSTEX: Operation not permitted

rm: PromiseSTEX.kext/Contents/MacOS: Operation not permitted

rm: PromiseSTEX.kext/Contents/Resources/PROMISE.icns: Operation not permitted

rm: PromiseSTEX.kext/Contents/Resources: Operation not permitted

rm: PromiseSTEX.kext/Contents/Info.plist: Operation not permitted

rm: PromiseSTEX.kext/Contents/version.plist: Operation not permitted

rm: PromiseSTEX.kext/Contents: Operation not permitted

rm: PromiseSTEX.kext: Operation not permitted


I have raised a support ticket with Promise.

Will post updates as I hopefully make progress on resolving this.


Raymond Sherman posted this 26 December 2021

My Pegasus 24TB R6 won't mount either on my MacBook Pro M1 Max either. What's up????