Clint Swires

  • Last Post 29 November 2021
Clint Swires posted this 24 November 2021

My cloud duo quit working, it is just flashing green. I have tried everything you recommended but it seems like the unit is not communicating. I rebooted it, the router, and change the cable. I am getting lights on the ethernet port but they are not blinking. 

When I open the unit up there are no lights on the hard drives. How do I do a data recovery of the hard drive? or is there something else I can do? 



Order By: Standard | Latest | Votes
Clint Swires posted this 24 November 2021

My router also recongnizes the unit is connected to my network but it is not sending any packets back to the router. 

R P posted this 29 November 2021

Hi Clint,

A flashing green light means that the Apollo is booting and has not yet connected to the public server.

Which means the Apollo App won't be able to talk to the Apollo.

Have you tried rebooting the router?

The Apollo needs to connect to the public server to be accessed. It looks like the Apollo is booting but not able to connect to the internet.

Modern hard drives don't have lights like older drives used to, but you'd have to take the Apollo apart to get to the drives so you could not look while it's powered on.

One option...

1. Get the Apollo's IP from the router and see if you can SMB connect to that IP. Use the same username/password you use for the Apollo App.

If you can SBM connect you should be able to copy off some data.