Can’t move, delete, rename or write files to Pegasus R6

  • 338 Views
  • Last Post 15 November 2019
Adam Dean posted this 14 November 2019

I just had two drives ‘die’ simultaneously on my Pegasus R6 which was setup for Raid 5. I know you should only be able to have one drive go down in Raid 5, but I was able to force mount one of the drives after which the utility app said there something about bad blocks on the drive that had been force mounted. The other drive remained dead

After a reboot the utility showed no issues (including no bad blocks) other than one dead drive which i replaced and tried a rebuild. That all seemed to go fine...  i ran media patrol which showed no issues. I also ran a redundancy check and again showed no issues...

Most of the data on the logical drive appears to be fine  and will open and run (a small amount seem to have corrupted.

However, when i try and move folders and certain files to a new drive I get an error -36 code (I’m on a Mac with Mojave). I can’t rename or delete an files or folders - that comes up with an error -50 code  and renamin*just gives a dialogue saying try a shorter name. I also cant write any new files or create new folders on the logical drive, nor will the pegasus eject - it says it is being used by something even with no apps or utilities open.  I ran disk utility first aid on it and again, that came back with no problems. 

basically the Pegasus utility is shwoung that everything is fine with all the drives and data but the fact I cant, write rename, delete or move any files from it means something is clearly wrong

 

sorry for the lengthy explanation, but any ideas of anything I might try to resolve this would be much appreciated

 

adam

Raghuraman Kannan posted this 15 November 2019

Hi Adam,

When 2 drives fail in RAID 5 setup , we could force mount the drive but we have to make sure that we use the command correctly . We should also keep the drive errors and the time which they failed in mind before using the command. Incorrect usage of the command, will lead to Data corruption (Which is likely in this case).

We would recommend you to open a case @ https://support.promise.com/ with the Service report, so that we can guide you on the next steps. Also backup the data from the folders you can, to avoid further more issues.

Thanks !

Close