Bad sector is found on physical disk, but which disk?

  • 65 Views
  • Last Post 27 February 2024
John Baughman posted this 26 February 2024

I just got a notification of "Bad sector is found on physical disk" on my Pegasus2 R4.

How do I know which disk needs to be replaced?  All of the lights on the front of the bays are blue.  Under "Runtime Events" The "Device" is listed as "PD 3".  Does this mean that the disk in the 3rd bay from the top needs replacement?

Joh

Order By: Standard | Latest | Votes
R P posted this 26 February 2024

Hi John,

If it's just one bad block I would not worry about it.

But if these are the original Pegasus2 drives and you get lots of bad blocks, then the drive should be replaced.

If you don't have a replacement drive on hand, perhaps now would be a good time to get one. Since the original drives are long out of production it's best to buy a new drive the same size or larger from the same manufacturer with the same rotation rate. Preferably get a surveliance drive and not a desktop drive.

John Baughman posted this 26 February 2024

Thank you for the reassuring response. The warning message says "Bad sector is found on physical disk".  The singular "sector" suggests it is only one sector.  So I'll just keep an eye on things and not panic yet.  It does indicate that it is a "Minor" severity.  I actually have two identical hard drives that I purchased to have on hand in case of a disk failure.  So I should be in good shape if the drive degrades further.

John

John Baughman posted this 27 February 2024

I thought the issue was resolved.  But this morning when I started up my computer I got another message about a bad sector.  This time, instead of one line I got a series of entries.  I don't know how to interpret this.  Does this mean I now have multiple bad sectors?

R P posted this 27 February 2024

Hi John,

Yes, definately multiple bad blocks.

You should replace PD3. PD3 is the 3rd disk from the top.

But before doing anything, are you using the RAID5 LUN that the Pegasus2 shipped with?

John Baughman posted this 27 February 2024

Pardon my ignorance about my set up.  I don't know what you mean by the "RAID5 LUN". How do I know if that is what I am using?

I am configured at RAID level RAID5 under the logical drive panel. I have four 2TB drives installed. All are "Toshiba DT01ACA2" model. 

I hope there is a user guide to help me with the drive replacement.

 

R P posted this 27 February 2024

Hi John,

I am configured at RAID level RAID5 under the logical drive panel.

OK, looks like the default configuration.

To proceed, you will need one of the replacement drives and a phillips screwdriver.

1. Hot unplug the failing drive PD3 (unplug while the Pegasus is on). The Pegasus buzzer will sound.

2. Put the replacement drive in the drive carrier, there are 4 phillips screws at the sides of the drive that hold the drive in the carrier.

3. Hot insert (insert while the Pegasus is on) the replacement drive into the PD3 slot. A rebuild should start.

In the Pegasus Utility you can see the progress of the rebuild in Background Activities, the blue button at the upper right.

It is best to not let the mac sleep until the rebuild is complete.

To silence the buzzer go to the Dashboard in the Promise Utility. There will be a red flashing icon near the top, click it and it will silence the buzzer.

John Baughman posted this 27 February 2024

I fear I have ruined everything!  I accidentally unplugged the drive in slot 1 while trying to figure out how to open the bays. I quickly re-inserted it but the indicator light turned red and stayed that way.  I went ahead and replaced the defective drive in bay 3.  But now I have all kinds of error messages and there is a red light on drive 1. The only encouraging thing is that the other 3 bays all have blue indicator lights and they are intermittently blinking.  I can hear drive activity coming from the unit.

Does this mean all is lost?

John Baughman posted this 27 February 2024

In the Background Activities it shows "Media Patrol Running" and under that PD ID 2 overall progress 3%running     Currendt PD Progress 7%.  This seems encouraging? But lower down where it says "Rebuild", it states that "Rebuild is not running".  There is a start button should I click it?

R P posted this 27 February 2024

Hi John,

Please email support@promise.com with the issue.

Please don't do anything else to the Pegasus.

John Baughman posted this 27 February 2024

Thank you for your advice. Request for help in progress.

John

Close