Apple Silicon support

  • 1.1K Views
  • Last Post 19 December 2020
Andrew Hall posted this 20 November 2020

The Pegasus R4 and R6 don't appear to be working with the new apple silicon (M1) devices. Wondering what the plans are to have the relevant software updated?

Order By: Standard | Latest | Votes
Ranjith kumar posted this 21 November 2020

Hi Andrew,

Since Pegaus R4 and R6 are legacy unit, there is no further update on this unit.

Please reach us through support.promise.com if any assistance needed.

Regards,

Promise Team

Andrew Hall posted this 21 November 2020

Thanks for your reply Ranjith. Are you affiliated with Promise?

It would be a shame to see perfectly good hardware go to waste because of a software issue.

John Tunison posted this 22 November 2020

Hope not affiliated w/ Promise as this would be a significant miss on their part.  I bought a Pegasus32 R6 with my new M1 mac mini and MBP, specifically to use with them, after verifying on both the Apple store and Promise websites that they specifically call out compatibility w/ M1 / Big Sur.  Fortunately Apple gave no resistance to my return.  But spent >1 hour on Apple tech support.  Gave up on Promise tech support after 3 "can I place you on a hold" follwed by 10-30 minutes on hold followed by hang up.  Guess they're stumped and can't stomach telling customers "sorry, it isn't working right now and we don't have a solution" followed by either "and we're working on it and expect something by MM/DD" or "and probably won't so might as well toss it in the garbage or return it if you can...good luck"

Barry Sharp posted this 22 November 2020

Ranjith:

Can you post back saying if Promise will be supporting or does currently support the TB3 Pegasus devices on the new Apple M1 models, such as the Mac mini (M1, 2020) ?

I have several TB1 & TB2 Pegasus devices that I've been using for some time now with my aging Intel-based Mac as a file server. It supports these TB1 and TB2 Pegasus devices without issues under MacOS Big Sur 11.1. I was hoping to replace this Intel-based Mac file server with the new Mac mini (M1, 2020). However, if Promise will not be supporting my TB1 and TB2 Pegasus devices with this new Mac mini (M1, 2020) I will be forced to abandon the use of the Apple M1 computer models. This is a GREAT shame, and I'm really disappointed with Promise if this is so (said as politely as I can).

To be clear here, I'm not refering to the hardware/software support for the Pegasus1 and Pegasus2 devices such as the R4/R6/R8, and understand they are no longer supported by Promise. What I'm wanting to know is Promise going to work with Apple or provide to the user the necessary software for the new Apple M1 models such as the Mac mini (M1, 2020) to support the 'legacy' Pegasus devices. I have the 'legacy' R4, R6 and R8 units and wish to use them with a new Mac mini (M1, 2020).

  • Liked by
  • Wayne Ratcliffe
R P posted this 23 November 2020

Hi Barry and Andrew,

I had requested information in regards to Pegasus M1 support and I now have an answer.

Promise will support the M1 architecture on Big Sur. The verification on Pegasus2/Pegasus3/Pegasus32 will be done in the middle of Dec. Verification won't be done with the Pegasus1, but it should be compatible. And this is true, I have tested the latest Pegasus32 MAC driver with my old Pegasus1 R4 and it worked with no issues. The Promise Utility identified the unit and I was able to rebuild a drive that had died and read and write data.

R P posted this 23 November 2020

 Hi Barry,

This is all the information I have. I'm sure there will be some manner of official announcement. As soon as I find out that the driver is available for download, I will post that information here.

  • Liked by
  • Barry Sharp
  • Palle Jensen
Barry Sharp posted this 23 November 2020

OK... So I will need to check back here now and then rather than receiving an e-Mail notification, right ?

Barry Sharp posted this 04 December 2020

Admin: Please let me know when this update for the Apple M1 architecture on Big Sur is aavailable, or when it will be available. I'm anxiously awaiting to have my Mac mini (M1, 2020) fully operational with its connections to my several Pegasus devices.

Thank you.

  • Liked by
  • Christopher Shenton
R P posted this 04 December 2020

Hi Barry,

When the driver has passed certification testing it will be posted to the Promsie Web page.

Unfortunatly, all I know now is that testing is in progress, I do not have an ETA better then mid to late December.

When the driver is available I will post the information to the forum.

  • Liked by
  • Christopher Shenton
  • Palle Jensen
Barry Sharp posted this 04 December 2020

Will you post the details here in this posting thread.... I simply do not want to miss the notification. Thank you.

R P posted this 15 December 2020

Hi Barry,

I have just discovered that the M1 Pegasus driver (v6.2.16) is now available for download on the Promise support page.

Or you can download it from this link...

Please read the install guide. Big Sur has security features that must be modified.

----

Enable System Extensions

M1 Mac running macOS 11 or later requires a one-time change to the Boot Policy before you install
the
Promise Pegasus Driver. Follow the instruction in this section if the Boot Policy setting has not
yet been changed. First check to see if the Boot Policy needs to be changed.

  • Liked by
  • Christopher Shenton
Barry Sharp posted this 16 December 2020

Hey..... Thanks very much for this update.

I followed all the installation instructions and foundthat the PromiseSTEX was list under System Information -> Extentions, but it displayed as being Notorized and NOT loaded.

I also noted that the new PromiseSTEX version 6.2.16 was placed into /Library/Extensions whereas in earlier macOSes for non M1 model Macs it (version 6.2.13) was placed/located in /System/Library/Extensions.

No matter, I went ahead and issued the following Terminal command to load the new PromiseSTEX version 6.2.16, and it did the trick and loaded the new PromiseSTEX version 6.2.13 driver. I checked this with System Information -> Extensions.

===========================================================

> sudo kextload /Library/Extensions/PromiseSTEX

password:

Executing: /usr/bin/kmutil load -p /Library/Extensions/PromiseSTEX.kext

===========================================================

Now of course, the real test for this is to see if my Mac mini (M1, 2020) will discover my Pegasus units and for them to be operational.

I ran Promise Utility and yes, my Pegagsus2 R6 was discovered.

My Finder showed it as being mounted in its sidebar.

So all is looking good at this time, and I also checked that my Pegasus1 R4 is also being discovered.... great.

So THANK YOU.

P.S. Please note that I had to manually load the PromiseSTEX which is not mentioned in the Installation instructions, or maybe I did something wrong.

When this gets released to Apple, I would expect the PromiseSTEX will be loaded without having to manuall install it in Terminal with the above command, right ?

 

 

Christopher Shenton posted this 16 December 2020

 

When this gets released to Apple, I would expect the PromiseSTEX will be loaded without having to manuall install it in Terminal with the above command, right ?

 

No need to load anything manually from my experiences. The notice switched to "loaded" once I connected the drive. So to sum it up: install according to manual and you will be fine. It worked for my M1 MacMini and Pegasus3 R4 like a bliss.

Barry Sharp posted this 16 December 2020

Christopher: Hmmmm, I'll check that aspect. I will Restart with my Pegasus unit connected to see if the driver is loaded as you've mentioned without having to load it manually. Thanks for the prompt.

 

[EDIT] ...and it did. So there's no need to manually load the driver after each boot..... THANK YOU for posting this aspect.

Ben Long posted this 19 December 2020

I was very excited to see this solution, but I'm afraid it's not working on my M1 Mac Mini. I've installed the new driver, per the instructions, and it appears in the System Report. I've activated it from the command line (by the way, the command listed above needs .kext at the end) and it appears as Loaded in the System Report. 

I've got the Pegasus 2 R4 connected to my Mini using the Apple Thunderbolt 2 to 3 adapter. When I turn on the Pegasus, it does its usually thing for a while, then the light turns blue. It sits there for a moment, and then shuts down. It never appears in the Finder. I've tried it several times, to no avail. I'm using the same cable that I was using to connect it to my Trash Can Mac Pro, so I'm confident the cable is good.

Any suggestions?

By the way, upon reboot, the new kext is not automatically loading. I have to re-issue the command every time.

Ben Long posted this 19 December 2020

Aha! Just did a firmware update on the drive and now it's working!

Close