Apple Cinema Display Not Working

  • 104 Views
  • Last Post 04 August 2020
Kevin Hale posted this 19 July 2020

I just upgraded from a Pegasus3 R4 to a Pagasus32 R4.

Under my old set up I had a Apple Cinema Display with Thunderbolt 2 cable connected to my Pegasus via a Mini Display to Thunderbolt 3 adapter.

Now with my Pgasus32 R4 unit, when I patch the cables the same way as before my Cinema Display will not turn on. 

If I daisy chain the Pegasus to another raid (a G Drive Raid) and then contect my monitor to the G Drive Raid, the monitor will work.  The G Drive Raid is 32TB and gets loud and hot, so I rather not have it running all the time.

Any ideas as to why I can't get my monitor working witht he new Pegasus32 R4?

Thanks for your help!

Order By: Standard | Latest | Votes
Ranjith kumar posted this 22 July 2020

Hi Kevin,

Pegasus32 have Display port 1.4 at backside of the unit, have you checked 

with monitor connecting to it.

Regards,

Promise Team

Kevin Hale posted this 22 July 2020

Hello,

Yes, I've tried using the Thunderbolt ports (I've tried both of them) and using the DP 1.4.  The monitor wouldn't come on for either of them.  I again tried using the monitor with the G Raid Drive and it worked fine, so I don't think it's a monitor issue.

Ranjith kumar posted this 24 July 2020

Hi Kevin,

Kindly reach us through support.promise.com to verify the issue and help you.

Regards,

Promise Team

Hyde Bean posted this 31 July 2020

same issue, does anyone have an idea about this, why does this happens FaceTime? Kindly give any relevant solution.

Kevin Hale posted this 04 August 2020

I got it working, but via the DP 1.4 port (which by the way, the person I talked to on the phone from Promise support said there's a compatibility issue with the Cinema Display and Pegasus, and what I did wouldn't work... but it did).

I got a DP 1.4 to Mini Display Port adapter on Amazon for 9 bucks. (https://www.amazon.com/dp/B014DV2RGG?psc=1&ref=ppx_pop_dt_b_product_details).  At first when I did this, like the tech said, it wouldn't work.  So, I basically gave up and have been waiting for the tech team to get back to me.

Today, however, when I installed some RAM on my computer I got the message that some software was blocked and I needed to allow it.   I went to System Preferences ---> Security & Privacy ---> clicked on the "General Tab" and then clicked on "Allow" at the bottom of the tab.  After clicking on "allow" I was taken to a panel where I could check a box to allow the RAM to work, however there was also a box showing that some Promise software was also being blocked.  I checked it, then plugged in my monitor and it worked!  

It only seems to have worked with using the DP 1.4 port.  It still wouldn't work using the Thunderbolt 3 port.  Not ideal, but I'll take it.

Good luck!

Close