Apollo DUO time machine suddenly failed

  • Last Post 14 January 2021
frank friedman posted this 12 January 2021

I've been using the Apollo Cloud Duo for years as a time machine backup and suddenly backups not occurring (last backup 1/8/21), no error message seen.  If I select a different, non Apollo, network hard drive (I have a Netgear Ready NAS+ as well) it works fine.  I've unplugged and replugged the Apollo, checked all cables (and have access to the regular Apollo drive with my pictures w/o problem).  Connected to my desktop by wifi or CAT cable.  I've selected and unselected the disk, mounted and unmounted the drive from the top bar at various points in the process, renamed the time machine, tried changing the password, etc.  It finds the Apollo drive but gets stuck in "Preparing backup" for about 5 minutes and then just quits.  Data is being sent/received under "Apollo Activity" in the dashboard.   I just tried to do a similar, new backup from my mac laptop to Apollo time machine drive and ran into the same problem.  No other changes to my system recently: Mac desktop, iOS 11.1, Apollo utility 2.1.10, says 2.53 TB of space available(33.2% used) RAID 1 configuration, firmware updates automatically.

Ranjith kumar posted this 14 January 2021

Hi Frank,

As per our conversation at web support case id:20210112125423S where backup started again, 

please reach us through case id if issue continues.

Thank you,

Promise Team