A-class is down because on raid is missing a hardrive

  • 471 Views
  • Last Post 04 August 2021
Mahmoud Ahmed posted this 18 July 2021

Hello

i'm facing a problem with my A-class unit and i really need anyone's help.

a couple of days back my head unit reports two dead hard drives and however there are two spare drives , that didn't make any difference. i teried toforce one of them online which was p19 and replaced the other one p12. But , after a while p19 reorted dead again and the rebuild failed .when i tried to put the old p12 in place ,it showed stale state and i tried to clear it with phydrv -a clear staleconfig .

i figured out after that , that i shouldn't do that as now the logical raid reports it missing a hard drive and i'm completely stuck with raid 5 contains one missing and one dead drives.

i'm thinking of completely delete the raid and recreate it with the same hard drives to see if that can help .But for sure any advice would be appreciated .

 

Regards

Mahmoud

 

Order By: Standard | Latest | Votes
Raghuraman Kannan posted this 20 July 2021

Hi Mahmoud,

We have replied to the case. Please check.

Since it is RAID 5 array, it cannot afford to have more than 1 bad drive. In your case, PD 12, PD 19 have errors. You have already tried to force online PD 19 but it went offline again becuase of bad sectors.. PD 11 also has lot of errors. So this array is beyond repair becuase of errors on 3 drives.

Thanks !

R P posted this 20 July 2021

Hi Mahmoud,

Unfortunartly 2 drive failures on a RAID5 is not recoverable by a rebuild.

But there are many data recovery services who can recover failed drives. Google gives many options.

https://www.google.com/search?&q=data+recovery+service

Mahmoud Al.Gendy posted this 04 August 2021

Hello

 

the faulty lun has been deleted and the i have  replaced the faulty drives too.

The problem now , after adding the new lun to the filesystem .it still seeing the old one as missing lun and i can not remove it .

 

i hope anyone can suggest a solution for this.

 

 

R P posted this 04 August 2021

HI Mahmoud,

You can add LUNs to expand the filesystem, but you still need all the LUNs in the filesystem for the filesystem to be online.

You can liken the A-class filesystem to a RAID0 LUN. If any drive in a RAID0 LUN dies, the data is no longer accessible. In this case you deleted a LUN that is part of the filesystem, that means that the filesystem is incomplete just like a RAID0 missing a drive. To bring the data back alive at least one of the dead drives would need to be restored by a data recovery service, with that drive the LUN would be online but critial and the filesystem would come back online. Then a rebuild could have been started. I'm not sure if anything can be done now.

Close