24tb pegasus32 doesn't turn on!

  • Last Post 2 weeks ago
Rolando Hernandez posted this 2 weeks ago

Hello, I have a Pegasus 32 of 24TB, only the box does not turn on and I already changed thunder and power cables and it does not turn on, what can I do, I am in Los Angeles, California.

Thanks for the help.

Order By: Standard | Latest | Votes
Dave Carson posted this 2 weeks ago

I am having the same problem with two R8's. Died when I attached to new M2 Mac Studio. I tried purchasing new power supplies, same model number but the wiring config is different. Support hasn't been very helpful. Any ideas?

Rolando Hernandez posted this 2 weeks ago

I moved the power cord and only tried turning it on once, I want to think it was the power box but I don't know where to order one.😞

Babatunde Akinkuolie posted this 2 weeks ago

Hello Rolando,


Thank you for contacting Promise Technology. In order to assist you further, please go our support website at: https://support.promise.comHere is the link about how to register your Pegasus and submit a ticket: